gem update --system is disabled on Debian

Blog ยป gem update —system is disabled on Debian

Posted on 26 Apr 2009 15:03

You are developing Ruby on Rails and you use Ubuntu Intrepid.

You somehow get

Rails requires RubyGems >= 1.3.1 (you have 1.2.0). Please `gem update --system` and try again.

and you go on:
gem update --system

You end up reading the error message:
ERROR:  While executing gem ... (RuntimeError)                                                 
    gem update --system is disabled on Debian. RubyGems can be updated using the official Debian repositories by aptitude or apt-get.

RubyGems 1.3.1 on Ubuntu 8.10 provides the solution.

If you like this page, please spread the word: diggdel.icio.usFacebook

You can contact me if you have questions or corrections.

Unless otherwise stated, the content of this page is licensed under Creative Commons Attribution-ShareAlike 3.0 License